• Sam Hocevar's avatar
    . all plugins now compile with -fPIC. · f8da8c95
    Sam Hocevar authored
     . made the audio_output API a bit simpler.
    
     . got rid of modules_config.h.
    
     . fixed `make install' rule.
    
     . fixed warnings in the MMX YUV compilation.
    
     . probably fixed a bug in the input : pp_foo structures were free()d at
       the end, but this was useless since the last call to realloc() is
       equivalent to free(), and two consecutive calls to free() aren't a
       goo idea.
    
     . we check that the version number match and that we don't already have
       a module by that name when loading a new module.
    
     . all public module_* functions now properly lock the module bank.
    
     . the audio_output now uses the new module API ; EsounD and DSP modules
       have been ported, which should be enough for Henri to port the ALSA one.
    
    
       The new plugin API is now much simpler ; it's now just a matter of
    calling module_Need( p_main->p_module_bank, MODULE_CAPABILITY_FOO, p_data );
    and if successful we get the best module. Capabilities can be ORed, so that
    one can ask for a plugin that does VOUT _and_ INTF actions for instance.
    
       It's not complete yet though -- by making it generic I had to do a few
    ugly casts here and there, which I am going to fix ASAP. Also, command line
    selection of a plugin does not work yet.
    
       The switch to the new plugin API has probably broken the BeOS audio
    output ; we can either wait until the whole vlc has switched to the new
    plugins, or create a separate beos_sound.so that conforms to the new API.
    f8da8c95
rules 1.8 KB
#!/usr/bin/make -f
# debian/rules for the VideoLAN Client - uses debhelper.
# based on Joey Hess's one.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This is the debhelper compatability version to use.
export DH_COMPAT=3

build: build-stamp
build-stamp:
	dh_testdir

	./configure --prefix=/usr \
		--mandir=\$${prefix}/share/man \
		--infodir=\$${prefix}/share/info \
		--enable-gnome --enable-fb \
		--with-ggi --enable-esd --with-glide \
		--with-sdl
	$(MAKE)

	touch build-stamp

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp

	-$(MAKE) distclean

	dh_clean

install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs

	$(MAKE) install prefix=`pwd`/debian/tmp/usr

	# make symlinks for packages
	for alias in ggi gnome fb glide esd sdl ; do \
		ln -s vlc debian/tmp/usr/share/doc/vlc-$$alias ; done
	ln -s vlc.1.gz debian/tmp/usr/share/man/man1/fbvlc.1.gz
	ln -s vlc.1.gz debian/tmp/usr/share/man/man1/gvlc.1.gz

	dh_movefiles

# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: build install
#	dh_testversion
	dh_testdir
	dh_testroot
#	dh_installdebconf	
	dh_installdocs
	dh_installexamples
	dh_installmenu
#	dh_installemacsen
#	dh_installpam
#	dh_installinit
	dh_installcron
	dh_installmanpages -Nvlc-gnome -Nvlc-fb -Nvlc-ggi -Nvlc-glide -Nvlc-esd -Nvlc-sdl
	dh_installinfo
#	dh_undocumented
	dh_installchangelogs -Nvlc-gnome -Nvlc-fb -Nvlc-ggi -Nvlc-glide -Nvlc-esd -Nvlc-sdl
	dh_link
	dh_strip
	dh_compress
	dh_fixperms
	# You may want to make some executables suid here.
	dh_suidregister
#	dh_makeshlibs
	dh_installdeb
#	dh_perl
	dh_shlibdeps -Nvlc-glide
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install